Technical Minimum Requirements for Amadeus e-Learning

 

In order to view our videos, please use the latest versions of Internet Explorer and Adobe Flash Player and ensure Adobe Flash player is fully enabled.

If you are still having problems, please check the following links: